السلام عليكم،،
تظهر هل هذه المشكلة عند تشغيل Sun Application Server
Starting Domain domain1, please wait. Log redirected to C:\Sun\AppServer\domains\domain1\logs\server.log. Domain domain1 failed to startup. Please check the server log for more details. CLI156 Could not start the domain domain1. Press any key to continue . . .
وفي ملف Server.log يظهر لي الخطأ:
[#|2005-11-03T18:32:31.385+0300|WARNING|sun-appserver-pe8.1_02|javax.enterprise.tools.launcher |_ThreadID=10;|LAUNCHER005: Spaces in your PATH have been detected. The PATH must be consistently formated (e.g. C:\Program Files\Java\jdk1.5.0\bin; ) or the Appserver may not be able to start and/or stop. Mixed quoted spaces in your PATH can cause problems, so the launcher will remove all double quotes before invoking the process. The most reliable solution would be to remove all spaces from your path before starting the Appservers components. |#]
كانت الجافا موجودة في الامتداد: c:/program files/java/jdk1.5.0_04/bin
وبسبب هذا الخطأ أعدت تثبيت الجافا وجعلته في الامتداد: c:/java/jdk1.5.0_04/bin
إلا أن الخطأ ما زال يظهر ولا سيما أن الامتداد لا يحوي على مسافات!!
ونظرت في الشبكة واكتشفت أن علي التأكد من ملف c:/sun/appServer/config/asenv.bat
ومراعاة أن تكون القيمة As_Java هي :
set AS_JAVA=C:\Java\jdk1.5.0_04
ولكن مع ذلك يظهر الخطأ الغريب..
كان يعمل منذ زمن...
طبعا نفس الخطأ يظهر عند تشغيل الخادم من NetBeans.