بسم الله الرحمن الرحيم
أردت اليوم تثبيت سيرفر mysql على توزيعة opensuse 12.3 لأغراض برمجية
وبعد التثبيت من مدير المستودعات بالأمر
sudo zypper in mysql
ابى السيرفر التشغيل بكل الأوامر الموجودة في ملفات المساعدة
وهذه الأوامر
rcmysql start /etc/rc.d/mysql start systemctl start mysql.service
وكان الجواب دائما
Failed to issue method call: Unit mysql.service failed to load: No such file or directory
وبعد البحث والتنقيب وجدت جوابا وحلا للمشكلة فأحببت أن أضعه هنا لدعم المحتوى العربي
الحل هو إنشاء ملف mysql.service المفقود
افتح التارمنال بصلاحيات الجذر واكتب فيه
nano /etc/systemd/system/mysqld.service
ثم ألصق فيه ما يلي
[Unit] Description=MySQL Server After=network.target [Service] ExecStart=/usr/bin/mysqld --defaults-file=/etc/mysql/my.cnf --datadir=/var/lib/mysql --socket=/var/run/mysqld/mysqld.sock User=mysql Group=mysql WorkingDirectory=/usr [Install] WantedBy=multi-user.target
ثم اضغط على ctrl+o للحفظ ثم ctrl+x للخروج
تنبيه أنا استعمل المحرر nano ولك الاختيار أي المحررات تستعمل
ثم نفذ الأمر التالي
systemctl daemon-reload
الآن يمكن تشغيل السيرفر بالأمر
/etc/rc.d/mysql start
ولكي تجعل السيرفر يشتغل عن كل إقلاع للنظام نفذ الأمر
su -lc 'chkconfig mysqld on'
