السلام عليكــم ورحمـة الله وبركاتــه ،،
لقد قمت برفع موقعي(www.filshabaka.qsh.eu) على www.qsh.eu و وضعت قاعدة البيانات في App_Data و غيرت جملة الاتصال و لكن عندما كنت أحاول الدخول الى موقعي يظهر هذا الخطأ الموضح في الصورة الأولى
و عنما أحاول الدخول على www.filshabaka.qsh.eu\Index.aspx يظهر لي :server error in application.
فقررت أن أضع الموقع في wwwroot على local IIS لتجربته أولا" و قمت
بإعدادات IIS المطلوبة كما هو موضح في موقع مايكروسوفت(في خصائص المجلد في IIS قمت بتعيين
anonymous access و Integrated windows security الى true) علما" بأن لدي IIS 5.1 و IIS 6.
و لكن عندما أحاول تصفح مشروعي يظهر لي الخطأ الموضح في الصورة الثانية
وعنما أختار صفحة Index.aspx يظهر لي هذا الخطأ الموضح في الصورة الثالثة
إذن المشكلة على ماأعتقد هي أن المشروع لم يهيئ ليعمل على جهاز الخادم و أيضا" أريد منح كل المستخدمين الصلاحية للدخول الى الموقع
لقد بحثت في كل المواقع و المنتديات الأجنبية ولم أتوصل إلى الحل و قمت بتنفيذ التعليمات الموجودة في موقع microsoft\support و رغم ذلك ما زالت المشاكل موجودة ، فأرجو مساعدتي لتلافي هذه الأخطاء
ملحوظة هامة:عندما أعمل run للمشروع في visual studio من على سيرفر الشركة المستضيفة أو حتى localIIS كان كان تظهر هذه الرسالة :
It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level.This error can be caused by a virtual directory not being configured as an application in IIS.
ملحوظة أخرى: لا داعي للذهاب الى العنوان في اعلى المشاركة لأني قد قمت بإزالة ملفاتي و قاعدة البيانات من على السيرفر


