الفريق العربي للبرمجةأرشيف المنتديات · 2000 – 2023
نسخة أرشيفية للقراءة فقط — التسجيل والمشاركة مغلقان، والمحتوى محفوظ كما كان.

مشكلة في ضبط الموقع على Iis

بدأه بهاء صلاح الدين في 27 يوليو 2009 · 7 رد · 1,594 مشاهدة · في ASP.NET
مشاركة: واتساب X فيسبوك تيليجرام
#1 صاحب الموضوع

السلام عليكــم ورحمـة الله وبركاتــه ،،

لقد قمت برفع موقعي(www.filshabaka.qsh.eu) على www.qsh.eu و وضعت قاعدة البيانات في App_Data و غيرت جملة الاتصال و لكن عندما كنت أحاول الدخول الى موقعي يظهر هذا الخطأ الموضح في الصورة الأولى

و عنما أحاول الدخول على www.filshabaka.qsh.eu\Index.aspx يظهر لي :server error in application.

فقررت أن أضع الموقع في wwwroot على local IIS لتجربته أولا" و قمت

بإعدادات IIS المطلوبة كما هو موضح في موقع مايكروسوفت(في خصائص المجلد في IIS قمت بتعيين

anonymous access و Integrated windows security الى true) علما" بأن لدي IIS 5.1 و IIS 6.

و لكن عندما أحاول تصفح مشروعي يظهر لي الخطأ الموضح في الصورة الثانية

وعنما أختار صفحة Index.aspx يظهر لي هذا الخطأ الموضح في الصورة الثالثة

إذن المشكلة على ماأعتقد هي أن المشروع لم يهيئ ليعمل على جهاز الخادم و أيضا" أريد منح كل المستخدمين الصلاحية للدخول الى الموقع

لقد بحثت في كل المواقع و المنتديات الأجنبية ولم أتوصل إلى الحل و قمت بتنفيذ التعليمات الموجودة في موقع microsoft\support و رغم ذلك ما زالت المشاكل موجودة ، فأرجو مساعدتي لتلافي هذه الأخطاء

ملحوظة هامة:عندما أعمل run للمشروع في visual studio من على سيرفر الشركة المستضيفة أو حتى localIIS كان كان تظهر هذه الرسالة :

It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level.This error can be caused by a virtual directory not being configured as an application in IIS.

ملحوظة أخرى: لا داعي للذهاب الى العنوان في اعلى المشاركة لأني قد قمت بإزالة ملفاتي و قاعدة البيانات من على السيرفر

post-158674-1248725229_thumb.jpg

post-158674-1248725770_thumb.jpg

post-158674-1248726026_thumb.jpg

تم تعديل هذه المشاركة بواسطة بهاء صلاح الدين فراج في 27 يوليو 2009 في 23:40

#2

يجب إعطاء صلاحية ليوزر ASPNET على قاعدة البيانات. و يتم هذا من الـSQL Server نفسه و ليس من الـIIS.

بالنسبة لهذا الخطأ

It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level.This error can be caused by a virtual directory not being configured as an application in IIS

فهذا معناه أن الفولدر الموجود فيه النظام لم يهيأ كـvirtual folder من الـIIS

#3

السلام عليكــم ورحمـة الله وبركاتــه ،،

الموقع يعمل جيدا" على localhost الآن .....شكرا" لك يا system down......

الآن تتبقى مشكلة error 403.14 - forbidden the web server is not configured to list the contents of directory .

الظاهرة في الصورة الأولى من المشاركة .... فما سببها؟

هل لأن شركة الاستضافة تستخدم IIS7 ؟

جربت كل الحلول الواردة في المواقع فأحدها يقترح عمل create للتطبيق من خصائص التطبيق في local iis قبل رفعه و جربت هذا الحل و مازالت المشكلة قائمة......

#4

ما هو اسم الصفحة الرئيسية؟ Default.aspx؟

قد تحتاج إلى تعيين اسم صفحة البدء في السيرفر.

#5

المشكلة تغيرت الآن ، عند محاولة الوصول للموقع تظهر رسالة الخطأ هذه (أنظر الصورة).

و هو هنا يطالب بأن أكتب السطر التالي في ملف config.web :<customerror mode="Off"/>

و ذلك حتى تظر تفاصيل الخطأ على الرغم من أن هذا السطر موجود بالفعل ! و قمت بتغيير القيمة Off إلى On و Remote only و لكن بدون فائدة ....

فما الحل هنا؟

ملحوظة هامة للأخ System down:

إسم الصفحة الرئيسية هو Index.aspx و لكن كبف أعينها كصفحة البدء في السيرفر؟

يخيل إلي أن المشكلة تكمن في ترتيب الملفات و المجلدات على السيرفر . صفحات المشروع متواجدة في المجلد (filshabaka) و قاعدة البيانات موجودة في المجلد App_Data و كلا المجلدين موجود في المجلد www فهل هذا هو السبب؟

أرجو المساعدة من الخبراء و المشرفين و لكم جزيل الشكر.....

post-158674-1248919281_thumb.jpg

#6

تأكد من أن العنصر customErrors ليس داخل <-- و <!-- التي تدل على أن العنصر يتم تجاهله. يمكنك فتح الملف في فيجوال ستوديو. العناصر المتجاهلة سيكون لونها مختلف.

بالنسبة للـindex.aspx. الوضع القياسي للـIIS هو أن تكون default.aspx هي صفحة البدء. إما أن تغير اسم الصفحة أو تغير إعدادات الـIIS (تحت بند Documents على ما أتذكر)

#7

السطر موجود بالفعل في ملف config.web و مع ذلك قمت بعمل ملف config جديد و أيضا" ما زالت المشكلة قائمة.

أخي system down ستجد ملف الconfig موجود بالمرفقات

إذا أردت مني أن أرسل لك جميع ملفات المشروع فأخبرني.....

Web2.rar

#8

السلام عليكــم ورحمـة الله وبركاتــه ،،

الحمد لله حللت المشكلة......

قمت بوضع بإخراج جميع الملفات من ملفها الأصلي و وضعها في ملف www ثم قمت بتغيير إسم قاعدة البيانات من in_the_net.mdf إلى in_the_net

و الموقع يعمل جيدا" الآن و تتبقى مشكلة أن النصوص بداخل butttons و labels غير مدعمة للعربية ...... و لكن يمكن حل هذه المشكلة أيضا"..

نصيحة للأصدقاء عند رفع الملفات غلى السيرفر : إذا كانت الملفات موجودة في مجلد إسمه mysite ، أخرجها منه و ضعها في مجلد www ثم قم بحذف إمتداد قاعدة البيانات.

أخي العزيز system down : شكرا" لك على مساعدتك و جعل الله هذا في ميزان حسناتك . :ty:

مواضيع مشابهة