الفريق العربي للبرمجةأرشيف المنتديات · 2000 – 2023
نسخة أرشيفية للقراءة فقط — التسجيل والمشاركة مغلقان، والمحتوى محفوظ كما كان.

مشكلة عند استعمال الجدول Security الموجود فى قائمة Web Site Administrator

بدأه OEA_73 في 26 مايو 2008 · 4 رد · 1,060 مشاهدة · في ASP.NET
مشاركة: واتساب X فيسبوك تيليجرام
#1 صاحب الموضوع

السلام عليكم،،،

مشكلة غريبة لم الاحظه أبداً، عند استعمالى لجدول SECURITY الموجود فى قائمة Web Site administrator

تظهر هذى الرسالة

There is a problem with your selected data store. This can be caused by an invalid server name or credentials, or by insufficient permission. It can also be caused by the role manager feature not being enabled. Click the button below to be redirected to a page where you can choose a new data store.

The following message may help in diagnosing the problem: An error occurred during the execution of the SQL file 'InstallCommon.sql'. The SQL error number is 1802 and the SqlException message is: CREATE DATABASE failed. Some file names listed could not be created. Check related errors. Cannot create file 'D:\WEB_SITE\ETAKNS\APP_DATA\ASPNETDB_TMP.MDF' because it already exists. Change the file path or the file name, and retry the operation. Creating the ASPNETDB_a7eb452ba6f24583a1ffbbc161dec357 database...

الغريب انى مسحة المجلد بتاع الدتا بيز ومافيش فايدة وكمان جربت تغيير الاسم ومافيش فايدة؟؟

لوكان فى احد عنده جواب على المشكلة ومرة عليها ايفيد نا وايفيد كل مشاركين المنتدى

وبارك الله فيكم ،،،،،،

#2

السلام عليكم

رسالة الخطأ تشيير الى الملف

D:\WEB_SITE\ETAKNS\APP_DATA\ASPNETDB_TMP.MDF'

انه موجود بالتالي لا يمكن انشاء القاعدة مرة اخرى

وبما انك حذفت المجلد لذا حاول انشاء موقع جديد وعمل هذه القاعدة به ومن ثم نسخها الى مشروعك الحالي

#3

وعليكم السلام ورحمة الله

  • تأكد من تشغيل مزود قاعدة البيانات الخاص بك (SQL server express مثلاً)
  • تأكد من أنك قمت بإعداد قاعدة البيانات الخاصة بك لاستخدام خواص العضوية والصلاحيات باستخدام الأداة Aspnet_regsql
  • تأكد من أنك قد قمت بضبط خواص العضوية والصلاحيات في ملف web.config (نرجو تزويدنا بهذا الملف إن أمكن(

سبحانك اللهم وبحمدك، أشهد أن لا إله إلا أنت، أستغفرك وأتوب إليك

أشرف صبري

#4

المشكلة بسيطة جداً.

افتراضياً تستخدم ASP.NET إعدادات افتراضية تتضمن ConnectionString اسمها LocalSqlServer.

و هذا الاتصال مرتبط بـ SQL Server Express Edition.

و لذلك يجب تشغيل SQL Server EXpress Edition أولاً حتى يعمل الموقع.

لتغيير هذا الأمر يمكنك أحد أمرين:

1- إلغاء LocalSQLServer ConnectionString من خلال القسم ConnectionStrings في الـ Web.Config و ذلك باستخدام <Clear/>.

2- إضافة خصائص جديدة للـ membership provider و تحديد الـ ConnectionString المطلوبة.

#5

طب أنا يا جماعة مشكلتي مختلفة شوية و إن كانت تشبه لمشكلة الأخ OEA_73 :

الرسالة اللي بتظهرلي كالتالي:

There is a problem with your selected data store. This can be caused by an invalid server name or credentials, or by insufficient permission. It can also be caused by the role manager feature not being enabled. Click the button below to be redirected to a page where you can choose a new data store.

The following message may help in diagnosing the problem: Unable to connect to SQL Server database.

و بعدين زرار: Choose Data Source

اللي طبعا مش بيوصلني للي انا عاوزه.

يعني باختصار, مش عارف ابدأ أصلا باستخدام الـ "Web Application Administration"

أرجو أن تفيدوني و شكراً مقدما

مواضيع مشابهة

عدد الزوار حالياً

المتواجدون خلال آخر دقيقتين · يتحدّث كل ٣٠ ثانية

—الإجمالي—أعضاء مسجّلون—زوار بدون تسجيل

جارٍ التحقق من المتواجدين…