الفريق العربي للبرمجةأرشيف المنتديات · 2000 – 2023
نسخة أرشيفية للقراءة فقط — التسجيل والمشاركة مغلقان، والمحتوى محفوظ كما كان.

فشلت في الاتصال بالسيرفر ارجوا المساعده

مغلق
بدأه toolbox في 17 يونيو 2007 · 3 رد · 807 مشاهدة · في قواعد بيانات Microsoft SQL Server
مشاركة: واتساب X فيسبوك تيليجرام
#1 صاحب الموضوع

احبائي

السلام عليكم ورحمة الله

هل هناك طريقة لاستشعار وجود سيرفر MS SQL Server 2005 على شبكة لان داخليه؟ هذا هو السؤال واليكم المشكله التي حصلت معي ولم استطع الاتصال بالخادم.

قمت بتوصيل جاهزين ببعضهما عن طريق شبكه لان باستخدام باتش كروس كيبل شبكه

لنفرض ان الجهاز A عليه mssql server 2005 واسمهserver1 والجهاز B عليه الفيجوال ستوديو وانا استخدم VB.Net 2005 كيف استطيع استشعار وجود او الاتصال ب server1 في الطرف الآخر بشكل صحيح مع العلم بانني حاولت وفشلت فهو لا يظهر لدي في server explorer والذي يظهر لدي تحت مجال servers هو اسم الكمبيوتر الذي اعمل عليه فقط

وهذه محاولتي:

حاولت ان أضيف اتصال add connection ومن ثم اختيار Microsoft SQL Server ومن ثم في خانة ال Server name اكتب له Server1 ومن ثم test connection ولكني فشلت تظهر هذه الرساله :

An error has occurred while establishing a connection to the server. When connecting to SQL Server 2005, this failure may caused by the fact that under the default setting SQL server does not allow remote connections.
(Provider: Named Pipes Provider, error:40-could not open a connection to SQL Server)

تقول بوجود احتمال ان السيرفر لا يسمح بالاتصال الطرفي فكيف احل هذه المشكله بارك الله فيكم ونفع بعلمكم

#2

بحمد الله تمكنت من حل المشكله واصبح اسم السيرفر يظهر ضمن مجموعة العمل work group في الجهاز الاخر وذلك بعد ان اوقفت عمل الجدار الناري في جهاز السيرفر.

وقد جربت ذلك عن طريق شبكه سلكيه وشبكه لاسلكيه وفي كلتا الحالتين تم الاختبار بنجاح

والان سوف اجرب الاتصال بقاعدة البيانات بالسيرفر عن طريق الفيجوال واوافيكم بآخر التطورات

محبكم تول بكس

#3

بعد طول محاولات لم تأتي بنتيجه مرضيه

من على السيرفر اضفت لوق ان جديد اسميته toolbox واعطيته كلمة مرور goodluck وعدت الى جهازي حاولت ان أضيف اتصال add connection ومن ثم اختيار Microsoft SQL Server ومن ثم في خانة ال Server name اخترت Server1 ثم اختار use sql authentication ثم اضيف اسم المستخدم toolbox وكلمة المرور goodluck ومن ثم test connection وكانت هذه الرساله تضهر لي عند كل محاوله:

Login failed for user 'toolbox', The user is not associater with a trusted SQL Server connection.

وان حاولت الدخول بطريقة use windows authentication تظهر نفس الرساله

Login failed for user , The user is not associater with a trusted SQL Server connection

هل من حل ؟

تم تعديل هذه المشاركة بواسطة toolbox في 18 يونيو 2007 في 04:27

#4

عند استخدام sql authentication لماذا لم تجرب sa .

ثانيا لاستخدام windows authentication اعمل مايلي

start --> run --> control userpasswords2

ستظهر شاشة المستخدمين توجد بها قوائم (tabs ) اختر خيارات متقدمة advance

ثم يوجد زر Manage passwords

تظهر شاشة جديدة اضف اليها مستخدم من السيرفر وكلمة المرور مثل server\administrator

هذا الموضوع مغلق.

مواضيع مشابهة

عدد الزوار حالياً

المتواجدون خلال آخر دقيقتين · يتحدّث كل ٣٠ ثانية

—الإجمالي—أعضاء مسجّلون—زوار بدون تسجيل

جارٍ التحقق من المتواجدين…