السلام عليكم ورحمة الله وبركاته
لدي قاعدة بيانات على جهازي الشخصي في المنزل
قمت بعمل كافة الإعدادات الضرورية لتمكين الاتصال بها من أي remote client عن طريق الإنترنت.
وبالفعل نجحت في الاتصال بالقاعدة من على أي حاسوب وذلك باستخدام ال IP Address الخاص بجهازي
ولكن بسبب أن مزود الإنترنت يعطي dynamic IP
فقد استخدمت الموقع www.no-ip.com لعمل اhostname خاص بحاسوبي
ولكن عند استخدام هذا hostname بدلا من IP Address لا يتم الاتصال ويعطي رسالة الخطأ
علما بأنني أستطيع استخدام hostname في أي متصفح انترنت للوصول لحاسوبي
TITLE: Connect to Server ------------------------------ Cannot connect to abbas100.servers.info. ------------------------------ ADDITIONAL INFORMATION: An error has occurred while establishing a connection to the server. When connecting to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server) (Microsoft SQL Server, Error: 53) For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft+SQL+Server&EvtSrc=MSSQLServer&EvtID=53&LinkId=20476
فما سبب هذه المشكلة
شكرا لكم