CSP MySQL User Manager Changelog
--------------------------------

2.3.1 - 2012-11-03

- Added: Function for genxml to require a key to generate the xml output.
- Added: Added/addedby/changed/changedby added to the csv import/export function.
- Added: Function to turn off/on php notices errors (debug mode).
- Added: Added 'js' folder to the robots.txt disallow list.
- Added: Better support for special characters.
- Added: Sorting after latest user first.
- Added: Function to create random usernames.
- Fixed: Charset error on the "you are not authorized" page.
- Fixed: &-char could cause genxml to stop working.
- Fixed: Removed unneeded mysql calls.
- Fixed: Secured tools from url hack.
- Changed: Removed the '::' in the page title.
- Changed: Locked the 'csp value' textboxes under 'importing profiles from csp' tool.
- Changed: New style for buttons.


2.3 - 2012-01-10

- Added: Iphone/Android favicon.
- Added: Ecm rate to default values.
- Added: Optimize database tool.
- Added: Database version check on login page.
- Added: Administrator level to admins (administrator/manager).
- Added: Function to change admin username.
- Added: Real name field for admins.
- Added: Setting to turn off csp connection check.
- Fixed: 'Add user and stay' didnt load the defaults values after a user were added if that function was turned on.
- Fixed: Mixed layout fixes on some pages.
- Changed: Removed Accounts Expiration from home page.
- Changed: Changed 'addeby' and 'changedby' to use admin.id insted of admin.name.


2.2.1 - 2011-10-27

- Fixed: Session variable on logout page was not set correctly.


2.2 - 2011-10-18

- Added: Better mysql error control.
- Added: Csp server connection check function.
- Added: Csp server connection check on all pages that uses it.
- Added: Csp server connection failed notice in header.
- Added: Setting to change random password characters and length.
- Added: Default user order setting.
- Added: Service name fetching from csp server for active sessions.
- Fixed: Unset variables on tools page.
- Fixed: Mis-sized tables in csp user info on manager users page.
- Fixed: Added user notification on manage users page didnt show.
- Fixed: Minor code modifications.
- Fixed: Error on listing online/active/idle users.
- Fixed: Improved fetch from csp server function to minimize mysql server load.


2.1 - 2011-07-17

- Added: Delete user-button on edit user page.
- Added: Logout confirmation prompt.
- Added: New add-/edituser function.
- Added: New confirmation style on login page.
- Added: Idle icon for idle users on manage users page.
- Added: Fetch data about each user from csp server. Click on the username on manage users page to show.
- Added: Custom csp values included in csp xml user export tool.
- Added: Ecm-rate field to users (requires csp usermanager that supports this, like the AdvXmlUserManager).
- Added: Start-date and expire-date  fields to users (requires csp usermanager that supports this, like the AdvXmlUserManager).
- Added: Acive-/idle users listing option on manage users page.
- Added: Expired users are listed with a yellow dot on the manage users page.
- Added: Expired users are shown on the home page.
- Added: Setting to change what will be shown in the extra column on manage users page (default: password).
- Fixed: Page layout on some pages.
- Fixed: Default listing on manage users page wasnt always by username.
- Fixed: Search on manage users page now includes all relevant user fields.
- Fixed: Username can no longer be changed to null (nothing).
- Fixed: Various layout bugs.
- Fixed: PHP notice error on manage users page on some apache configurations.
- Fixed: Better online/offline/idle check on users from csp server.
- Changed: Moved favicon.ico to www root to avoid apache errors.
- Changed: Merged some files together and removed unused files.
- Changed: '10 Latest Failed Login Attempts' only shows if there has been any failed login attempts and logging is enabled.
- Changed: Removed one column add-/edit user page.
- Changed: Switched places on displayname and the extra column on manage users page.


2.0.6 - 2011-02-15

- Added: Custom csp values on userinfo page.
- Added: Custom csp values as default value.
- Added: Password must be given 2 times and match when changing then password for a admin.
- Added: SQL server checks in upgrade script.
- Added: Custom csp values to csv user import and export.
- Fixed: Typo in configcheck.
- Fixed: Csp xml user import got broken in version 2.0.5.
- Fixed: Username and password must be included when importing users, else import will skip that user.
- Fixed: Export users to csv output.
- Fixed: Some tools didnt get selected when choosing them under tools.
- Fixed: Improved update csp users tool.
- Fixed: Improved send osd message page layout.


2.0.5 - 2011-02-12

- Added: Back button on user info page.
- Added: Setting to show/hide send osd message link.
- Added: Replace function for invalid chars on add-/import users.
- Added: Custom csp values field for users. Makes it possible to output custom values into the genxml output for special/homemade versions of csp.
- Added: Upgrade script for database upgrades.
- Fixed: Profile '*' is auto removed from import list.
- Changed: Send osd link is hidden by default.
- Changed: Default is now 2 columns add user page.


2.0.4 - 2011-01-01

- Added: Tool to export user database to csp xml config code.
- Added: Tool to export user database to csv format.
- Added: Function to change username for users.
- Added: Function to create a random password for a new user.
- Added: Function to send osd messages to users.
- Added: Tool to import profiles from csp server.
- Fixed: Layout bug with status messages on the 2 columns add user page.
- Fixed: Some typos on the profile pages.


2.0.3 - 2010-12-26

- Fixed: 'Clear fields'-button didnt show on 2 columns add user page.


2.0.2 - 2010-12-26

- Added: 'Clear fields'-button on add user page that clears all fields.
- Fixed: Kick user function didnt work with HTTPS.
- Fixed: Status was not showed correct when use defaults was used on add user page.
- Changed: Default listing to username on manage user page.


2.0.1 - 2010-12-03

- Fixed: GENXML.PHP did only output 1 profile even if user had more.
- Fixed: PHP Undefined offset error when importing users from csv.
- Fixed: When importing users profiles were stuck through the hole import process.
- Fixed: Users with no profile(s) was added with bad data when importing from csv.


2.0 - 2010-12-02

- Added: Settings page for various settings.
- Added: Default values on add user page. Can be set on settings page.
- Added: Session timeout function, will kill a idle admin connection if it has been idle longer then given time. Timeout can be changed on settings page (default: 600 seconds).
- Added: Comment field added to users.
- Added: Tool to import users from csv
- Added: Profile manager for managing profiles.
- Added: New tool page with various tools.
- Added: Setting to hide all text from login page.
- Added: Function to log all failed login attempts.
- Added: Setting to show/hide help icons from the add user page.
- Added: Tool to delete all disabled users.
- Added: Tool to enable/disable all users.
- Added: Setting to give the c.m.u.m server a custom name.
- Added: Information page to show all the info about a user.
- Added: Setting to fetch various data from given csp server.
- Added: Tool to fetch/install new user files to csp.
- Added: Function to show if a user is online on the csp server.
- Added: Tool to import users from csp xml config.
- Added: Tool to empty the entire user database.
- Added: Function to kick a online user from the csp server.
- Added: Quick enable/disable users by clicking on their status icon.
- Added: Setting to change layout on add-/edit user pages to 1 or 2 columns.
- Added: More info on the home page.
- Added: Email-address field to userdatabase.
- Added: New profile handling system.
- Added: Warning message if config.php is not setup correctly or not found.
- Added: Group field to userdatabase.
- Added: Created and last changed logging added to users.
- Added: Admin accounts can now be set as enabled or disabled.
- Added: Charset is now configurable from config.php (default: utf-8).
- Added: Different color for odd and even lines on user-/admin-/profile listing.
- Added: List after online users on manage users page.
- Added: Update-users command is sent to csp server on logout if 'fetch data from csp server' is active.
- Added: Charset setting to genxml.php (default: utf-8).
- Added: Border around all input buttons.
- Added: MySQL connection check, will show a error if it's not possible to connect to the MySQL server.
- Fixed: Add-/edituser handling.
- Fixed: Various layout bugs.
- Fixed: Minor layout improvements for internet explorer.
- Fixed: The 'maxconnections=0' bug.
- Fixed: Auto remove of empty spaces in beginning and end of textfiled 'quicked' and 'search' on the manage users page.
- Fixed: Cancel-button didnt work on edit profile page.
- Fixed: Modified the code to prevent PHP Notice errors.
- Fixed: List option "Disabled users" now also lists users with NULL as enabled value.
- Fixed: Max connection field only accepts numbers.
- Changed: Most of the mysql code.
- Changed: Some mysql field types to speed it up a bit and to save some storage.
- Changed: Replaced "Profile(s)" with "Password" on manage users page.
- Changed: Moved the mysql server info into genxml.php so it can be placed anywhere on a server.
- Changed: Changed "mySQL" into "MySQL" in the name to follow the officiall name of the database.


1.0.1 - 2010-08-24

- Fixed: WSOD (white screen of death) bug


1.0 - 2010-08-06

- First stable release