• 0
mohamed mo

مشكلة - Emulator terminated in netbeans

سؤال

السلام عليكم ,,

انا استخدم netbeans 6.9.1 على ويندوز 7

وعندي مشكلة لما بعمل run بيطلعلى ال error دا وال emulator مش بيظهر

*** Error ***
Failed to connect to device 0!
Reason:
Emulator 0 terminated while waiting for it to register!

21-02-201107-48-10.png

0

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه

13 إجابة على هذا السؤال .

  • 0

اعمل clean and build للبرنامج

ان لم يعمل

حاول ان تستخدم

Emulator اخر

0

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه
  • 0

- عملت clean and build وبرضه نفس ال error :sad:

- بالفعل استخدمت emulator اخر وهو Java Wireless Toolkit وبقي بيشتغل بس ال emulator بقى بيختفي لوحده على طول بعد ما يظهر بحوالى 15 ثانيه :sad:

0

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه
  • 0

هل لك ان تضع الكود الذى تعمل عليه ؟؟؟

ان لم تكن به مشكله

فربما توجد مشكله فى النسخه التى لديك

انا دائما ما تواجهنى مشاكل فى هذه النسخه لذلك انا اعمل على 6.7 او 6.8

0

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه
  • 0

اوك .. سأحاول تنزيل نسخة 6.7 او 6.8 واجرب تاني :mellow:

0

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه
  • 0

نزلت نسخة 6.8 وبرضه نفس المشكلة

ولما استخدمت ال emulator دا Java Wireless Toolkit برضه نفس المشكلة بيختفي لوحده على طول بعد ما يظهر بشوية :sad:

0

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه
  • 0

نزلت نسخة 6.8 وبرضه نفس المشكلة

ولما استخدمت ال emulator دا Java Wireless Toolkit برضه نفس المشكلة بيختفي لوحده على طول بعد ما يظهر بشوية :sad:

طب ممكن ترفق الكود الذى استخدمته لذلك

اشك فى ان الكود به exception لذلك يقوم بالاغلاق او شىء هكذا

0

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه
  • 0

لا دا new project من غير ما ازود فيه حاجة !!

0

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه
  • 0

هل لك صلاحيات Administrator على الجهاز؟

تأكد ايضا من ال Anti-Virus و ال Firewall

0

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه
  • 0

اه قفلت ال firewall وال antivirus

0

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه
  • 0

حدثت معي مشكلة قديمة قد تكون مشابهة

و كان سببها اسم المستخدم لاحتوائه على احرف خاصة مثل (')

و مرة اخرى كان بسبب موقع تنصيب البرنامج و موقع المشروع

---

ليس لدي حل مباشر صدقا.

لكن مثلا حاول تكوين مستخدم جديد و تنصيب ال Netbeans عليه و المحاولة من هناك

0

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه
  • 0

اشكركم جدا جدا

بس يا ريت لو حد وصل لحل لهذه المشكله يضعه هنا.

وشكرا جزيلا لكم

0

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه
  • 0

اذا كنت تعمل على windows 7 تأكد من عمل run as adminsitrator لل NetBeans

اذا كنت تعمل على Windows 64 فهناك مشاكل على ما اذكر في ال emulator، جرب المشروع على Windows 32

0

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه
  • 0

تفضل أخي هذه الخطوات وستحل المشكلة بإذن شاء الله

1- افتح قائمة tools فى ال netbeans

2- ثم java platforms

3- ثم اختر من الشمال Java platform micro edition

4- ثم اضغط من اليمين refresh

وربما تواجهك مشكلة شبيهة فى حالة إذا أردت عمل debugging والحل انسخ الخطأ الذي ظهر لك وضعه في جوجل ستجد من ضمن النتائج أنه يرشدك إلى ملف ما -لا أذكر اسمه- من ملفات الjme platform لتكبير حجم الذاكرة

0

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه

من فضلك سجل دخول لتتمكن من التعليق

ستتمكن من اضافه تعليقات بعد التسجيل



سجل دخولك الان

  • يستعرض القسم حالياً   0 members

    لا يوجد أعضاء مسجلين يشاهدون هذه الصفحة .