• 0
Shadi Habbal

تشغيل OSPF و BGP لربط 4 AS

سؤال

السلام عليكم ورحمة الله وبركاته،

لدي الشبكة المبيّنة أدناه التي قمت بتصميمها في برنامج GNS3 وفقاً لمتطلبات المشروع الذي أعمل عليه.

post-7008-018302500 1287179854_thumb.png

لدينا 4 Autonomous Systems جميعها تعمل ببروتوكول IGP هو OSPF

ويتم الربط بينها جميعاً بواسطة بروتوكول EGP هو BGP

الأهداف هي:

1- تفعيل بروتوكولات التوجيه بحيث تصبح جميع الأجهزة قادرة على الوصول إلى بعضها البعض (يمكن التأكد من ذلك من خلال الأمر ping مثلاً)

2- لا يسير النظام AS4001 المعطيات بين النظامين AS2001 و AS3001

3- يفضل AS1001 المرور إلى AS4001 عبر AS3001

قمت بتفعيل البروتوكولات وإعداد الراوترات لكن لم أستطع حتى الآن تجاوز المشكلة التالية:

- الراوترات التالية لا تستطيع التواصل مع الواجهات الشبكية المحددة إلى جانب كل منها

R12

> 211.1.1.1

> 213.1.1.1

> 213.1.1.2

R32

> 211.1.1.2

> 212.1.1.1

> 212.1.1.2

> 212.1.2.1

R41

> 211.1.1.1

بينما تكون الراوترات والواجهات الشبكية غير المذكورة أعلاه قادرة على التخاطب مع بعضها البعض (للتحقق من الإعدادات عن طريق ping مثلاً)

تم إرفاق إعدادات جميع الراوترات التي قمت بها، الملفات محمية بكلمة سر والسبب واضح، لا أريد لأحد استغلال جهدي.

سأرسل كلمة السر لمن يطلبها عبر الرسائل الخاصة بهدف تقديم حلول عن الأسئلة الواردة أعلاه للحصول على النقاط و/أو الاستفادة والإفادة.

ينتهي منح النقاط الساعة 9 مساء بتاريخ 17/10/2010 أي يوم الأحد (غداً)

لكن، لأني أطمع في معرفة الحل إن لم يكن هناك إجابات خلال الفترة القصيرة هذه، سأعيد فتح السؤال في أي وقت لاحق وأمنح 10 نقاط لمن لديه الإجابة.

بالنسبة للطلبين 2, 3 فهناك عدة حلول يمكن اتباعها وأنا أعرف بضعاً منها سلفاً لكن لم يتبقى لدي وقت.. حيث أني بحاجة إلى إعداد تقرير العمل أيضاً ولهذا أطرحها في الموضوع أيضاً.

سأختار الإجابة الأنسب إلى المعطيات لدي (حيث هناك أوامر على نسخ IOS جديدة لا يمكنني الاستفادة منها لأن الهدف أساساً تنفيذ الشبكة على برنامج Boson NetSim لكن النسخة التجريبية لا تدعم جميع الأوامر ومن غير المعروف إصدار IOS الذي تتم محاكاته وعليه أنشأت هذا المشروع الفرعي)

يمكن للاستفسار استخدام التعقيبات على الموضوع (بدون فتح مشاركة جديدة) وسأجيب عنها في أسرع وقت إن شاء الله.

تحديث: قمت بإرفاق نسخة عن تصميم الشبكة بدون كلمة سر.

شكراً للمتابعة.

Routers config.rar

2

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه

19 إجابة على هذا السؤال .

  • 0

الحل في المرفق مضغوط بنفس كلمة السر الخاصة بالضغط الأول .. القضية كالتالي :

بالنسبة للمشكلة الأولى : لم تقم بعمل advertisement للنكات التي توصل راوترات ال BGP بالأمر network , ففي ال BGP عموما الأمر Nieghbor مهمته هو عمل ال adjacency فقط بين الراوترات لكن لاتوجد أي شبكة تستطيع الراوترات معرفتها إلا تلك التي توصلها سويا بشكل مباشر بالتالي بعمل advertisement لكل اللنكات تستطيع الراوترات الغير متصلة إتصال مباشر معرفة كل شيء ..

لاحظت أنك أنشئت default static route للراوترات الداخلية التي تعمل بال ospf , خيار جيد لأن الراوترات الداخلية ليس لديها إلا gateway واحد فقط ..

بالنسبة للقضية الثانية : أن تمنع أي مصدر بيانات صادر من AS3001 أن يصل ل AS2001 عن طريق AS4001 والعكس أيضا , فهذه تحتاج إما لعمل community tagging من المصدر ثم عمل الفلترة في 4001 بناء على ذلك , أو أن تستخدم as-path access-list وهو ماقمت بإستخدامه هنا في router 41:


ip as-path access-list 1 deny ^3001_

ip as-path access-list 2 deny ^2001_

route-map TO_3001 permit 10

match as-path 2

route-map TO_3001 permit 100

route-map TO_2001 permit 10

match as-path 1

route-map TO_2001 permit 100

router bgp 4001

neighbor 210.1.2.1 route-map TO_2001 out

neighbor 210.1.3.1 route-map TO_3001 out

وهي تقول لأي prefix صادر من 3001 وذاهب في إتجاه ال nieghbor 210.1.2.1 out للخارج أي في ال outbound , قم بفلترته ..

وأيضا العكس أي prefix ناشيء من 2001 وذاهب ل 3001 فلتره ..

لكن لو كانت البيانات عابرة فقط مجرد عبور كما سيحدث في الحالة رقم 3 فلا مشاكل ..

النقطة الثالثة : المطلوب أن البيانات الموجودة في AS1001 تفضل العبور عبر 3001 للوصول ل 4001 , فهذه كما ذكرت أنت يمكن إستخدام ال weight فيها وهو خيار جيد جدا , لكن ال weight ك attribute وهو الأثقل على الإطلاق ويفضل على أي attribute آخر , لاينتقل لبقية الراوترات بشكل آلي في نفس ال autonomous system , بالتالي تحتاج أن تعدل ال weight لكل interface في كل راوتر مع كتابة route-map لعمل ال matching أيضا .. وهي عملية مرهقة خصوصا لو كانت عدد الراوترات كبير في AS , لذلك يفضل إستخدام ال Local Preference وهو ال attribute رقم 2 في الأولوية ويأتي بعد ال weight مباشرة , حيث هو transitive وينتقل مع ال prefix التي يتم عمل advertisement لها لبقية الراوترات لكن داخل نطاق ال Autonomous System فقط . كالتالي :


ip as-path access-list 1 permit _4001$

!

!

route-map TO_4001 permit 10

match as-path 1

set local-preference 1000

router bgp 1001

neighbor 210.1.1.2 route-map TO_4001 in

لاحظ أنني عدلت على الراوت المتجه ل 4001 ليصبح ال local preference له 1000 , حيث أن الإفتراضي لل EBGP 100 ولل iBGP أظنه 0 .. لست متأكد جدا من هذه النقطة لكن بأي حال هذه هي النتيجة :


R11#sh ip bgp

BGP table version is 71, local router ID is 211.1.1.1

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path

*> 210.1.1.0 0.0.0.0 0 32768 i

*>i210.1.2.0 211.1.1.2 0 100 0 i

*>i210.1.3.0 210.1.2.2 0 100 0 4001 ?

*> 210.1.4.0 210.1.1.2 1000 0 3001 4001 ?

*>i210.1.5.0 211.1.1.2 0 100 0 i

* i211.1.1.0 211.1.1.2 0 100 0 i

*> 0.0.0.0 0 32768 i

*>i212.1.1.0 210.1.5.2 0 100 0 2001 i

*>i212.1.2.0 210.1.5.2 2 100 0 2001 i

*>i213.1.1.0 210.1.2.2 0 100 0 4001 3001 i

*> 214.1.1.0 210.1.1.2 1000 0 3001 4001 i

ونفس القضية من R12 أيضا :


R12#sh ip bgp

BGP table version is 93, local router ID is 211.1.1.2

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path

r>i210.1.1.0 211.1.1.1 0 100 0 i

* 210.1.2.0 210.1.2.2 0 0 4001 ?

*> 0.0.0.0 0 32768 i

*> 210.1.3.0 210.1.2.2 0 0 4001 ?

* 210.1.5.2 0 2001 4001 ?

r>i210.1.4.0 210.1.1.2 0 1000 0 3001 4001 ?

r 210.1.2.2 0 0 4001 ?

r 210.1.5.2 0 0 2001 ?

* 210.1.5.0 210.1.5.2 0 0 2001 ?

*> 0.0.0.0 0 32768 i

* i211.1.1.0 211.1.1.1 0 100 0 i

*> 0.0.0.0 0 32768 i

* 212.1.1.0 210.1.2.2 0 4001 2001 i

*> 210.1.5.2 0 0 2001 i

* 212.1.2.0 210.1.2.2 0 4001 2001 i

*> 210.1.5.2 2 0 2001 i

* 213.1.1.0 210.1.5.2 0 2001 4001 3001 i

Network Next Hop Metric LocPrf Weight Path

*> 210.1.2.2 0 4001 3001 i

r>i214.1.1.0 210.1.1.2 0 1000 0 3001 4001 i

r 210.1.2.2 0 0 4001 i

r 210.1.5.2 0 2001 4001 i

R12#ping 214.1.1.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 214.1.1.1, timeout is 2 seconds:

!!!!!

لاحظ توجد لراوتس أخرى لكنها غير مستخدمة وفيها RIB failure لأسباب موجودة في ال configs التي أرسلتها , حيث أن بروتكول ال ospf يعمل بين بعض ال neighbors جنبا لجنب مع ال EBGP وتركتها في حالها لكنها لاتؤثر على سير العمل الذي إقترتحته وهي التي سبب ال RIB failure حيث أن ال route القادم من ال E2 OSPF أفضل في ال Administrative distance من اللنك الخاص بال iBGP حيث أن العلاقة بين R11-R12 هي iBGP وليست EBGP وال AD لل iBGP = 200 وبالنسبة لل EBGP = 20 وبالنسبة لل OPF = 110 , بالتالي ال ospf مفضل على iBGP لذلك تلاحظ أن ال route إلى 214.1.1.0/24 سيخرج عن طريق ال OSPF حتى يصل ل 3001 بعدها بال BGP يذهب ل 4001 , لكن المسار كما إقترحته إنت في السؤال ... لو أردت تعديلها وإبعاد ال ospf أخبرني ..

لكن يكفي أن تلغي ال ospf neighbor relationship بين R11-R32 وأن تقوم بعمل redistribute connected لل ospf وبعدها سيتم عمل ال redistribution مباشرة لل BGP لأن الجملة موجودة فعلا ..

أو يمكن أن تغير في ال AD لراوت ال OSPF ليصبح 210 مثلا ويكون أسوأ من ال iBGP بعدها ستختفي علامة ال RIB-Failure ويتم تثبيت راوت ال iBGP .

أيضا لو لاحظت وتركت ال router لمدة بدون كتابة أوامر ستتوقف الشاشة والمعالج سيعمل ب 100% لحل هذه المشكلة وهي الدخول في timeout للكونسول :


enable

conf t

console 0

exec-timeout 0 0

exit

أيضا للتحقق من ال reachability end to end إستخدم سكربت ال TCL التالي كوبي بيست في الراوتر مباشرة , وأضف أي آيبي تريد أن تتأكد منه أيضا ..


tclsh

foreach i {

211.1.1.1

210.1.5.1

213.1.1.1

212.1.1.1

212.1.2.1

214.1.1.1

} {ping $i}

gns3_configs.rar

2

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه
  • 0

رائع يا H

قمت بقراءة مشاركتك بشكل سريع، النقطة الوحيدة التي توقفت عندها هي في توضيح المشكلة الأولى..

بالنسبة للمشكلة الأولى : لم تقم بعمل advertisement للنكات التي توصل راوترات ال BGP بالأمر network , ففي ال BGP عموما الأمر Nieghbor مهمته هو عمل ال adjacency فقط بين الراوترات لكن لاتوجد أي شبكة تستطيع الراوترات معرفتها إلا تلك التي توصلها سويا بشكل مباشر بالتالي بعمل advertisement لكل اللنكات تستطيع الراوترات الغير متصلة إتصال مباشر معرفة كل شيء ..

إن كان ما فهمته صحيحاً أنت تقول بأني لم أستخدم الأمر network لعمل advertisement للشبكة التي يديرها الـ AS ؟ كيف ذلك وقد راجعت الملفات المرفقة وتأكدت من استخدام الأمر network. برجاء توضيح هذه النقطة لي إن كان ما قصدته مغاير لما فهمته.

سأجلس الآن لمراجعة المشاركة بتمعن وتطبيق ذلك على الشبكة وأعود لمنح النقاط إن شاء الله :)

0

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه
  • 0

نعم فعلت جزء منها لكن لم تفعلها كلها , مثلا لاحظ في R32 من الكونفق الخاصة بك سابقا :


router bgp 3001

no synchronization

bgp log-neighbor-changes

network 213.1.1.0

neighbor 210.1.1.1 remote-as 1001

neighbor 210.1.3.2 remote-as 4001

no auto-summary

لاحظ الأمر network موجود فقط لعمل advertisement للشبكة الداخلية وهي ليست مهمة أيضا لأن عملية ال redistribution من ال OSPF كانت ستقوم بها , لكن الأهم هنا الأمرين الجدد :

network 210.1.1.0 255.255.255.0

network 210.1.3.0 255.255.255.0

وهي نفس تلك التي في الأمر neighbor كما تلاحظ , أيضا التي كتبتها في الكونفقس الخاصة بي كانت بدون ال subnet mask وأظنه سيأخذ ال prefix كما هو في ال interface مع الماسك , مع أني أذكر أن أي خطأ في كتابة الماسك في الأمر network في ال BGP ستفشل العملية .. عموما يبدو أنه يتعامل كال RIP ...

أيضا في R41 لاحظ الأمر network غير موجود هناك ! لأنني إستخدمت شيء مقارب وهو عمل redistribution لل connected interfaces جميعا .. بالتالي بالتأكيد كافية جدا بالأمر :

redistribute connected

لكن في الملف المرفق أعلاه لم تكن الأوامر network في BGP process موجودة إلا لل networks الداخلية وهذا غير كافي .

0

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه
  • 0

أجدت يا H

مشاركتك كانت بمنتهى الدقة والوضوح :)

كما يقال "أستااااااااذ"

تم منح النقاط.

لدي استفسارات متعلقة بالموضوع لفهم بعض الأفكار:

1- تم حقن OSPF في AS1001 من خلال R11 فقط، وتم إلغاء الحقن من خلال R12 وذلك بإزالة

redistribute bgp 1001

هل السبب هو أنه يكفي حقنها من خلال ASBR واحد ؟ أم يجب حقنها من خلال ASBR واحد ؟ أم سبب آخر ؟

2- ما سبب تفعيل BGP في R31 ؟ أتصور أنه typo لكن الأفضل التأكد..

3- ألاحظ أنه تم إلغاء حقن BGP في OSPF في جميع الراوترات عدا R11، ما التفسير ؟

0

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه
  • 0

انتبهت إلى أن التالي بحاجة لتصحيح خفيف

neighbor 210.1.2.1 remote-as 1001

neighbor 210.1.2.1 route-map TO_2001 out

neighbor 210.1.3.1 remote-as 3001

neighbor 210.1.3.1 route-map TO_3001 out

neighbor 210.1.4.2 remote-as 2001

ليصبح

neighbor 210.1.2.1 remote-as 1001

neighbor 210.1.3.1 remote-as 3001

neighbor 210.1.3.1 route-map TO_3001 out

neighbor 210.1.4.2 remote-as 2001

neighbor 210.1.4.2 route-map TO_2001 out

لأن المطلوب هو المنع بين AS2001 و AS3001 بينما 210.1.2.1 تعود على AS1001

0

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه
  • 0

هل السبب هو أنه يكفي حقنها من خلال ASBR واحد ؟ أم يجب حقنها من خلال ASBR واحد ؟ أم سبب آخر ؟

لو كان ال redistribution يجب أن يكون من طرفين كما هو الوضع الطبيعي لل ASBR يعني OSPF->BGP & BGP->OSPF , في هذه الحالة كان إحتجنا لل R12 , لكن نحن نريد فقط أن نقوم بعمل Advertisement للراوتز الداخلية في الشبكة الداخلية وقد تكون هناك راوترات و client , Stub networks كثيرة لذلك إحتجنا لعمل redistribution ليتمكن جهاز طرفي بعيد في AS أخرى الوصول للكلاينت الآخر في AS1001 , الآن ال R11 لديها نسخة كاملة من شكل ال topology الخاصة بال OSPF في الشبكة بالتالي هو كافي لأنه سيحقن الراوتز في BGP وستصل ل R12 عن طريق iBGP ..

لكن لو كانت هناك راوتز خارجية من جهة R21 ك OSPF نحتاج وصولها للداخل في AS1001 لإحتجنا لعمل redistribution في R12 .

2- ما سبب تفعيل BGP في R31 ؟ أتصور أنه typo لكن الأفضل التأكد..

نعم بالضبط typo , وهو client ويكفيه default route فقط كما جهزته أنت ...

- ألاحظ أنه تم إلغاء حقن BGP في OSPF في جميع الراوترات عدا R11، ما التفسير ؟

أيضا typo :P , كنت أريد إلغاءه من كل الراوترات , والسبب أن ال OSPF من إسمه هنا IGP لايحتاج لمعرفة الكثير عن العالم الخارجي , يكفيه فقط أن يعرف أين ال Gateway لديه وهذا مايفعله ال default route تماما , طبعا ال OSPF بروتوكول معقد جدا ويثير الأعصاب وفيه مرونة كبيرة جدا عندما تتعقد الأمور .

لذلك بشكل عام EBGP وهو المستخدم في الإنترنت والذي أخيرا أعرف أنه هناك حوالي 400 ألف راوتر تقريبا تشكل شبكة الإنترنت , وحوالي 35 ألف Autonomous System أيضا .. الحد الأقصى لل AS =mimetex.cgi?2^{16}-1

لكن تم حل المشكلة بما يعرف بال communities وصيغة جديدة .

بالمناسبة لازلت أحبو حبوا , ربما زحفا :D

0

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه
  • 0

لو كان ال redistribution يجب أن يكون من طرفين كما هو الوضع الطبيعي لل ASBR يعني OSPF->BGP & BGP->OSPF , في هذه الحالة كان إحتجنا لل R12 , لكن نحن نريد فقط أن نقوم بعمل Advertisement للراوتز الداخلية في الشبكة الداخلية وقد تكون هناك راوترات و client , Stub networks كثيرة لذلك إحتجنا لعمل redistribution ليتمكن جهاز طرفي بعيد في AS أخرى الوصول للكلاينت الآخر في AS1001 , الآن ال R11 لديها نسخة كاملة من شكل ال topology الخاصة بال OSPF في الشبكة بالتالي هو كافي لأنه سيحقن الراوتز في BGP وستصل ل R12 عن طريق iBGP ..

لكن لو كانت هناك راوتز خارجية من جهة R21 ك OSPF نحتاج وصولها للداخل في AS1001 لإحتجنا لعمل redistribution في R12 .

ماذا لو توقفت البوابة من جهة R11 ؟
0

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه
  • 0

في هذه الحالة ستختفي ال network 211.1.1.0/24 من كل مكان ...

يمكن أن تقوم بعمل redistribute connected بدلا من ال OSPF لأن المثال صغير , لكن لو كان هناك عدد راوترات كبير في AS1001 تعمل بال ospf بالتأكيد ستحتاج أن تفعل ال redistribution في راوتر آخر منفصل , وفي الغالب يكون كلا البروتكولين يعملان OSPF + iBGP في نفس ال AS , ولو أن ال ospf لوحده فقط كافي .

يمكن أيضا مثلا أن تجعل الراوتر يقوم بعمل advertisement للراوت في حالة تعطل إنترفيس معينة في R11 مثلا .. إذا أردت أن تتحدث عن ال redundancy وال backup وال load balancing فكل شيء ممكن تقريبا ..

0

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه
  • 0

لماذا تختفي وهناك R12 يقوم بعمل إعلان عن أنه يملك route إلى 211.1.1.0 من خلال الأمر network 211.1.1.0 ؟

0

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه
  • 0

لماذا تختفي وهناك R12 يقوم بعمل إعلان عن أنه يملك route إلى 211.1.1.0 من خلال الأمر network 211.1.1.0 ؟

آه صحيح نسيت ال iBGP بين الراوترين لكن هل أعلنا عنها ؟ لاأذكر الكونفقس لكن لو كانت هناك جملة network واحدة كافية جدا .. ال iBGP تتعقد عندما يصبح هناك أكثر من راوترين مربوطين بال iBGP عندها تدخل في مشاكل وجوب ظهور full mesh بين الراوترات .. الخ

لكنك ممتاز جدا بالنسبة لشخص بدأ حديثا , يمكن أن تتعلم كل شيء في فترة وجيزة للغاية , لو أردت نصيحتي واصل المشوار :)

0

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه
  • 0

آه صحيح نسيت ال iBGP بين الراوترين لكن هل أعلنا عنها ؟

نعم لكن من ناحية أخرى لم نقم بحقن OSPF داخل BGP منها (كما سلف وتكلمنا سابقاً) بالتالي الأجهزة في AS أخرى لن تعرف إلى أي راوتر تتجه في حال كان الطلب إلى internal router خلف R12 على شبكة مختلفة عن 211.1.1.0 (أتكلم بشكل عام لا تنظر إلى تصميم الشبكة في الأعلى)

صح؟

ال iBGP تتعقد عندما يصبح هناك أكثر من راوترين مربوطين بال iBGP عندها تدخل في مشاكل وجوب ظهور full mesh بين الراوترات .. الخ

rule of sync

rule of split horizon

rules are made to be broken man laugh.gif

لكنك ممتاز جدا بالنسبة لشخص بدأ حديثا , يمكن أن تتعلم كل شيء في فترة وجيزة للغاية , لو أردت نصيحتي واصل المشوار :)

إن شاء الله :)

شهادة أعتز بها.

0

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه
  • 0

صح؟

نعم بالضبط ...

rule of sync

rule of split horizon

rules are made to be broken man

ياريت لو هكذا فقط , موضوع ال full mesh وال confederation أو ال Route reflectors مع أنهم ليسو معقدين لكن المزيد من البهارات :lol:

0

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه
  • 0

ياريت لو هكذا فقط , موضوع ال full mesh وال confederation أو ال Route reflectors مع أنهم ليسو معقدين لكن المزيد من البهارات :lol:

قرأت قليلاً حول RRs في مشكلة split horizon لكني لم أتعمق بعد.

أتمنى أن تكون البهارات من النوع الذي أحبه tongue.gif

0

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه
  • 0

احييك x على طرح الموضوع بكل هذه التفاصيل والمعطيات والوضوح

اعجبتني اجابات h وما تلاها من نقاش ,, لم اتمكن من تركيب اللاب إلا متأخرا بعد رفع ملف net ,,

0

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه
  • 0

احييك x على طرح الموضوع بكل هذه التفاصيل والمعطيات والوضوح

اعجبتني اجابات h وما تلاها من نقاش ,, لم اتمكن من تركيب اللاب إلا متأخرا بعد رفع ملف net ,,

والله يا أخي newbie وما أوتينا من العلم إلا قليلا.

التحية لهيثم فإن كان هو يحبو حبواً فأنا لم أولد بعد smile.gif

0

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه
  • 0

newbie , لو أمكن ضع تصور لحلك أيضا لتعم الفائدة فقد تكون هناك طرق أفضل :)

وجزاكم الله خيرا ...

0

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه
  • 0

تنبّهت أثناء تطبيق الإعدادات ومراجعتها إلى أن AS2001 تكون مكشوفة لـ AS3001 من خلال AS4001 (أي أن الـ route يكون distributed من خلال AS4001) وهذا يتنافى مع أهداف الطلب الثاني في الموضوع.

كان الحل سريعاً من HGB وذلك بعد محاولاتي الفاشلة لحل الموضوع بالابقاء على استخدام as-path-access-list بدلاً من استبدالها بـ access-list البسيطة blush.gif

أثناء البحث في المشكلة اكتشف H مشكلة أخرى في إعدادات الراوتر R11 لم أكن قد انتبهت إليها من قبل (كما قلت .. أستاااذ :))

وهذا اقتباس لرسالته عبر الخاص

كان هناك مشكلتين الأولى عدلتها أنت ولم أنتبه لتعديلك وهي typo بخصوص ال filter في R41 حيث لم يكن البير مع ال R21 في الفلتر ,

المشكلة الثانية كانت من الفلتر نفسه , غيرت الصيغة للعكس وإشتغلت بشكل جيد .. لاحظ الجملة deny ..

المشكلة الأكبر كانت في R11 لم يستطع أن يرى أي شيء يخص الراوت 213.1.10/24 مع أنه بجانبه تماما !! المشكلة كانت من أن ال route-map في نهايتها تكون هناك implicit deny :S ونسيت أن أكتب السطر الإضافي الخاص بالراوت ماب

route-map TO_4001 permit 100

exit

وبالتالي تم فلترة كل شيء قادم من R32 إلى R11 , المهم تأكد من الحل حاليا , تأكدت من الطرفين من R21 و R32 بال tracroute ومن جدول ال BGP لاأحد سيستخدم 4001 للوصول لمبتغاه .

في المرفقات تجدون ملفات الإعدادات للشبكة بالإضافة إلى الـ topology المصممة على GNS بدون كلمة سر :) لتكون الاستفادة أكبر ما يمكن، علماً أن وقت تسليم المشروع قد انتهى ولم يعد هناك قلق من نشره :)

gns3_configs.rar

1

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه
  • 0

تم استخدام الأمر network في كل الراوترات التي يعمل عليها bgp , بالإمكان ان نضيفها فقط في R11 لإضافة 210.1.1.0 وفي R12 لإضافة 210.1.5.0

0

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه

من فضلك سجل دخول لتتمكن من التعليق

ستتمكن من اضافه تعليقات بعد التسجيل



سجل دخولك الان

  • يستعرض القسم حالياً   0 members

    لا يوجد أعضاء مسجلين يشاهدون هذه الصفحة .