• 0
sof1ane

pygtk في windows

سؤال

السلام عليكم

املك مفسر في الويندوز python2.6 المشكلة عند محاولة تنصيب مكتبات pygtk قمت بتنصيب ثلاث ملفات و هما كالتالي

لتثبيت المكتبة على الوندوز يجب اولا تحميل و تنصيب

Gtk+ Runtime

http://ftp.gnome.org/pub/gnome/binaries/win32/gtk+/2.18/gtk+-bundle_2.18.7-20100213_win32.zip

ثم يجب تحميل و تنصيب

PyCairo

http://ftp.gnome.org/pub/GNOME/binaries/win32/pycairo/1.8/pycairo-1.8.6.win32-py2.6.exe

و ايضا

PyObject

http://ftp.gnome.org/pub/GNOME/binaries/win32/pygobject/2.20/pygobject-2.20.0.win32-py2.6.exe

و اخيرا

PyGTK

http://ftp.gnome.org/pub/GNOME/binaries/win32/pygtk/2.16/pygtk-2.16.0+glade.win32-py2.6.exe

المشكلة في الملف الاول فهو عبارة عن ملفات اين انسخها

تم تعديل بواسطه sof1ane
0

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه

6 إجابة على هذا السؤال .

  • 0
To fully install this bundle you need to uncompress its contents in a folder and manually add the bin subfolder to the system path.

فك الضغط وضيف مجلد bin لمتغيرات البيئة Enviroment Variables

0

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه
  • 0

السلام عليكم

أستاذاي الكريمان

لقد قمت بكل ما ذكر خطوة خطوة.

في البداية قمت بتنصيب python 2.6

ثم فككت الضغط عن الملف الأول و وضعته داخل مجلد python 2.6

بعد ذلك نصب البرامج الثلاثة الباقية بالترتيب المذكور

ثم قمت بتنصيب البرنامج الأخير الذي أشار له الأستاذ ahmed_youssef

بعد ذلك وجت أن مجلد bin أضيف لمتغيرات البيئة path

قمت بكتابة

import gtk في محث بايثون فلم تظهر رسالة خطأ أي أن المكتبة تعمل

هذا جيد حتي الآن ولكن لما قمت بتنصيب برنامج pyscript لم يعمل. أنا لا أعرف إصداره لكنه يعمل مع python 2.5

لذا أريد روابط لكافة الملفات السابقة لكن تعمل علي python 2.5

وشكرا

0

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه
  • 0

السلام عليكم

هذا جيد حتي الآن ولكن لما قمت بتنصيب برنامج pyscript لم يعمل. أنا لا أعرف إصداره لكنه يعمل مع python 2.5

لذا أريد روابط لكافة الملفات السابقة لكن تعمل علي python 2.5

وشكرا

تقصد برنامج pyscriptor

اذا كان كذلك فهو لا علاقة له بالتوليفة السابقة

هذا لينك المشروع

http://code.google.com/p/pyscripter/

اما نثبيت كل من gtk,pygtk,pycairo,pygobject

فهو لتقوم بكتابة برامج تعمل بهذه المكتبات

0

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه
  • 0

السلام عليكم

تقصد برنامج pyscriptor

اذا كان كذلك فهو لا علاقة له بالتوليفة السابقة

من قال ذلك. أنا قلت أن pyscriptor الذي عندي يعمل فط مع python 2.5

و طلبت و أكرر طلبي روابط لكل البرامج السابقة تعمل علي python 2.5

أو علي الأقل إصدار آخر ل pyscriptor يعمل علي python 2.6

وشكرا.....

0

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه

من فضلك سجل دخول لتتمكن من التعليق

ستتمكن من اضافه تعليقات بعد التسجيل



سجل دخولك الان

  • يستعرض القسم حالياً   0 members

    لا يوجد أعضاء مسجلين يشاهدون هذه الصفحة .