• 0
hasan_aljudy

هل يمكن تحديث الكرنل فقط دون بقية النظام؟

سؤال

السلام عليكم,

جهازي اللابتوب حاليا يستخدام لينوكس منت 7 gloria و المبني على اوبونتو 9.04 jaunty

و الجهاز يحتوي على بطاقة فديو مدمجة من انتل, و يبدو ان التعريف الموجود في الكرنل 2.6.28 فيه الكثير من المشاكل .. و هي تظهر في بطئ تشغيل بعض انواع الفديو (خصوصا HD) و كذلك الالعاب.

جربت الاصدار الجديد من اوبونتو 9.10 karmic من الـ Live CD حيث سمعت ان الكرنل الجديد يحل مشاكل تعريف بطاقات الفديو من انتل, و بالفعل شاهدت فرق واضح جدا,

و الان اصبحت عديم الصبر و اريد الكرنل الجديد!!

هل يمكن تنصيب اوبونتو فوق لينوكس منت (من دون فقدان البرامج و اعداداتها؟)

او, هل يمكن تحديث الكرنل فقط (حتى ولو يدويا) من دون التأثير على بقية النظام؟

تم تعديل بواسطه hasan_aljudy
0

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه

8 إجابة على هذا السؤال .

  • 0

نعم ، يمكنك تحديث الكرنل أو أي شيء في النظام دون أن تؤثر على النظام ، فهذه من ضمن مزايا نظام لينوكس.

خذ هذا الرابط

http://www.cyberciti.biz/tips/compiling-linux-kernel-26.html

وأي سؤال أنا في الخدمة.

0

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه
  • 0

سبق لي ان جربت ان ابني mplayer من السورس, فوجدت نواقص كثيرة (كودكس و ما شابه), و يبدو ان المسألة في الـ configuration

لهذا لا احبذ ان اقوم ببناء الكرنل بنفسي من السورس, لاني لا اعرف شيئا عن الـ configuration الخاصة به ولا الـ modules و لا الدرايفرات و لا اي شيء من ذلك.

الا توجد طريقة اخرى؟ الا يمكن اخذ الكرنل من الـ live cd مثلا؟ الا توجد ادوات معينة لتحديث الكرنل فقط؟

0

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه
  • 0

ابحث عن deb package الخاص بالتوزيعة التي عندك.

يعني مثلا ، ستجد حزمة بنفس هذا الاسم تقريبا

kernel-PAE-2.6.29.4-167.i686.deb

ابحث عن الموقع الذي يدعم توزيعتك ، وستجد فيه الباكج إن شاء الله.

وكل ما عليك هو تنصيب هذه الحزمة فقط.

لكن المشكلة التي يمكن أن تواجهها ، هي هل تم عمل حزمة لآخر إصدار للكرنل ، لذا التنصيب من source code أفضل في هذه الحالة.

بالنسبة لموضوع mplayer ، هناك حزم خاصة بال codecs وهي موجودة في موقع mplayer نفسه.

0

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه
  • 0
سبق لي ان جربت ان ابني mplayer من السورس, فوجدت نواقص كثيرة (كودكس و ما شابه), و يبدو ان المسألة في الـ configuration

لهذا لا احبذ ان اقوم ببناء الكرنل بنفسي من السورس, لاني لا اعرف شيئا عن الـ configuration الخاصة به ولا الـ modules و لا الدرايفرات و لا اي شيء من ذلك.

الا توجد طريقة اخرى؟ الا يمكن اخذ الكرنل من الـ live cd مثلا؟ الا توجد ادوات معينة لتحديث الكرنل فقط؟

لا تحتاج معرفة اي شيء ، فقط ستقوم بنسخ اعدادات النواة الحالية التي تعمل عليها و عند عمل التحويل ستقوم باستيراد هذه الاعدادات و سيتم التحويل بناء عليها (لكن ما المتعة في ذلك ، يجب العبث قليلا باعدادات النواة :P ) ، المشكلة الوحيدة ان الموضوع يستغرق بعض الوقت و في الاساس الموضوع يتوقف على امكانيات جهازك (كنت اقوم بعملية تحويل النواة على جهازي بانتيوم 4 و ذاكرة 512 و كان يحتاج حوالي اربع ساعات لاتمام العملية)

بالمناسبة القي نظرة هنا ، "لا عناء مع تهيئة النواه بعد الأن...." اعتقد موضوع مفيد جدا : )

طريقة اخرى ممكن اضافة مخازن التوزيعة الحديثة و تحديث النواة ، لكن غالبا سيطلب تحديث بعض الاشياء الاساسية في النظام لتتواقف مع النواة مثل مكتبات سي الخاصة بجنو (libc6)

تم تعديل بواسطه Skeleton_Eel
0

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه
  • 0

وجدت هذا الموضوع في البحث

http://www.ramoonus.nl/2009/11/05/linux-ke...r-ubuntu-linux/

و هو يتحدث عن تنصيب الكرنل من ملفات deb من موقع اوبونتو

اتبعت التعليمات (للنسخة 2.6.31.6) و فعلا تم التنصيب بنجاح, و لكن هناك مشكلتين:

- عند الاقلاع, تكون الشاشة سوداء, و قبل ذلك تظهر رسالة بان الـ video mode غير معروف

- من حين لاخر ترتجف الشاشة لمدة جزء من الثانية ..

- قبل قليل كنت اشاهد فلما و فجأة انطفأت الشاشة (و لكن الجهاز استمر في العمل) مما اظطرني لاطفاء الجهاز "بالقوة" و اعادة تشغيله

ماللذي يمكن ان يكون سبب هذه المشاكل؟ احد عنده فكرة؟

0

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه
  • 0

جاء في خاطري X11 ، حاول أن تحدثه

0

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه
  • 0

و هذا الاخر منين احضر اخر تحديث متوافق مع ubuntu/mint؟ :lol:

هل يمكن ان يكون السبب ان يكون هذا الكرنل من الـ main-line و ليس الكرنل الخاص باوبونتو؟ ام انه لا فرق بين الـ configurations؟

0

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه
  • 0

قمت باجبار منت على التحديث الى karmic كما وصفته في هذا الجواب في superuser

قمت بتعديل الملف

/etc/lsb-release

الى:

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=9.04
DISTRIB_CODENAME=jaunty
DISTRIB_DESCRIPTION="Ubuntu 9.04"

و قمت بعمل التحديث و مشي الحال :happy:

0

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه

من فضلك سجل دخول لتتمكن من التعليق

ستتمكن من اضافه تعليقات بعد التسجيل



سجل دخولك الان

  • يستعرض القسم حالياً   0 members

    لا يوجد أعضاء مسجلين يشاهدون هذه الصفحة .