qaher

لما أسوي أمر من اوامر اوراكل بالدوس مثل EXP يطلع لي بحروف غريبة

16 ردود في هذا الموضوع

لما أسوي أمر من اوامر اوراكل بالدوس مثل EXP يطلع لي بحروف غريبة

شوفوا المرفق التالي

شنوا الحل ياجماعة الخير

تقبلوا التحيات

0

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه

لما أسوي أمر من اوامر اوراكل بالدوس مثل EXP يطلع لي بحروف غريبة

شوفوا المرفق التالي

شنوا الحل ياجماعة الخير

تقبلوا التحيات

post-100503-1175280090_thumb.gif

0

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه

الأخ الفاضل ذلك بسبب اللغة العربية .. وهي مشكلة في عدم التعرف على محارف صحيحة ..

لذلك يجب تغير اللغة إلي الإنجليزية حتى تضهر لك رسائل التقرير بالإنجليزي ...

وليست مشكلة في التصدير ولكن يجب ان يكون الأمر معاك صحيح ..

EXP scott/tiger file = c:\1.dmp

يفضل لحل هذه المشكلة ان تقوم مباشرة بعد تحميل windows إذا كانت انجليزية تحميل oracle بعد ذلك قم بعمل تعريب للـ windows وبالتالي سوف تتفادى هذه المشاكل ... حيث ستدعم القاعدة العربي وتضهر بالإنجليزي بالنسبة للواجهات وايضا بالنسبة لرسائل التقارير ...

هناك مواضيع تتحدث حول الترميز للغة العربية في oracle حاول البحث عنها ...

بالتوفيق

تم تعديل بواسطه فواز الشمري
0

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه

السلام عليكم

طيب انا عندي

الونديز امجليزي

بس هاي المشكله عندي كمان

شو الحل؟؟؟؟؟؟؟؟؟؟

0

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه

حتى انا عندي نفس المشكله

؟؟؟؟؟؟؟؟

0

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه

طيب لو عملت مثل ماقلت ونزلت الويندوز وقبل ما أعرف العربي

وقمت نزلت الأوراكل

رح اواجهة مشكلة ثانية وهي ان الأوراكل رح ينزل ما يدعم العربي

ولو افترضنا عملنا السابق

في نهاية المطاف لازم اعرب الويندوز عربي

واتصور رح ترد نفس المشكلة في الدوس

=====================================

هل من حل اكيد ياشباب

وانا متأكد ان المشكله هاذي موجودة عند 95% من الشباب والزوار العرب اللي منزلين اوراكل على بيءة عربية

تقبلوا التحيات

0

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه

طبعا مع العلم لا يوجد اي مشاكل لا بالتصدير والاستيراد

لكن المشكلة تكمن لو جيت ابي استخدم تفاصيل اوامر اوراكل على الدوس

0

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه

يا أخواني : الرجاء إستخدام البحث قبل السؤال .....

إبحث عن NLS_Language و كيفية تغييرها إلى الإنكليزية ....

0

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه

ممكن حتى ولو واجهة الإستخدام عندك إنجليزي تظهرلك هذه المشكلة وذلك لأنك إخترت اللغة الإفتراضية لعمل البرامج بها عربي .

إذهب إلى لوحة التحكم ومن ثم خيارات اللغة .

ومن ثم Advanced ومن ثم تحت : إعداد اللغة لـ : Language For non-Unicode programs :-

إختر : English .

سيطلب منك قرص الويندوز ومن ثم إعادة التشغيل وبعد إعادة التشغيل قم بتغيير الـ NLS_language بالأوراكل وقم بتغيير Nls_lang

إلى :

AMERICAN_AMERICA.AR8MSWIN1256

وعلى فكرة إذا أردت أن تعرف الـ NLS_Language لقاعدة البيانات قم بتنفيذ الأمر التالي :

select * from database_properties

وأرجو أن تعمل معك لأنها عملت معاي تمام والحمد لله .

وبالتوفيق ..

0

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه
يا أخواني : الرجاء إستخدام البحث قبل السؤال .....

إبحث عن NLS_Language و كيفية تغييرها إلى الإنكليزية ....

انا قرأت الحل اللي موجود بالدورة اللي (ادارة قواعد البيانات) انت كتبتها

وعملت الخطوات لكن

ما انحلت المشكله لغاية الآن

0

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه

غيرت اللغة من

إذهب إلى لوحة التحكم ومن ثم خيارات اللغة .

ومن ثم Advanced ومن ثم تحت : إعداد اللغة لـ : Language For non-Unicode programs :-

إختر : English .

ونفس المشكلة

وعملت

select * from database_properties

والنتيجة هي

SQL> SELECT * FROM NLS_DATABASE_PARAMETERS;

PARAMETER VALUE
------------------------------ ----------------------------------------
NLS_LANGUAGE AMERICAN
NLS_TERRITORY AMERICA
NLS_CURRENCY $
NLS_ISO_CURRENCY AMERICA
NLS_NUMERIC_CHARACTERS .,
NLS_CHARACTERSET AR8MSWIN1256
NLS_CALENDAR GREGORIAN
NLS_DATE_FORMAT DD-MON-RR
NLS_DATE_LANGUAGE AMERICAN
NLS_SORT BINARY
NLS_TIME_FORMAT HH.MI.SSXFF AM

PARAMETER VALUE
------------------------------ ----------------------------------------
NLS_TIMESTAMP_FORMAT DD-MON-RR HH.MI.SSXFF AM
NLS_TIME_TZ_FORMAT HH.MI.SSXFF AM TZR
NLS_TIMESTAMP_TZ_FORMAT DD-MON-RR HH.MI.SSXFF AM TZR
NLS_DUAL_CURRENCY $
NLS_COMP BINARY
NLS_LENGTH_SEMANTICS BYTE
NLS_NCHAR_CONV_EXCP FALSE
NLS_NCHAR_CHARACTERSET AL16UTF16
NLS_RDBMS_VERSION 10.2.0.1.0

20 rows selected.

SQL>

ومازالت المشكلة مستمرة

وعلى فكرة أخ حسام عملت بحث وماحصلت حل!

ويش تتوقعون المشكلة؟؟؟

0

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه

أخي أعمل إعادة تشغيل للجهاز .

وإذا ما إنحلت المشكلة يبدو أنه يجب إعادة تشغيل OUI والتأكد من اللغات التي قمت بتنصيبها مع الأوراكل ومن ثم التأكد من تنصيب اللغة الإنجليزية .

ومن ثم إعادة تشغيل الجهاز وتأكد من موضوع الريجستري لأنه مهم جداً

إبدأ --> تشغيل --> Regedit ومن ثم :

إذهب إلى المسار التالي :

HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE

وقم بالبحث Ctrl+F عن :

nls_lang

وأضغط على الملف الذي تجده بهذا الإسم مرتين وأكتب :

AMERICAN_AMERICA.AR8MSWIN1256

و إضغط F3 مرة أخرى إلى أن تغير جميع الملفات التي تجدها .

ومن ثم إعد تشغيل الجهاز .

وإن شاء الله ستحل المشكلة .

0

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه

قم يتجربة ما كتبه الأخ إبراهيم ...

0

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه
و إضغط F3 مرة أخرى إلى أن تغير جميع الملفات التي تجدها .

الف شكر لك اخي

كانت المشكله انني لم اعدل كل

nls_lang

مشكور وبارك الله فيك

4.gif

0

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه

الحمد لله انحلت المشكلة .

0

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه

يسلموووووووووووووووووووووو

ضبطت 100%

يا ابراهيم بخش

اول شيء عدلت في ملف واحد بس

وما تصلحت المشكلة

وبعدين وبعد رد nahid

ركزت على

و إضغط F3 مرة أخرى إلى أن تغير جميع الملفات التي تجدها .

فغيرت جميع الملفات

وصلحت المشكلة

جزاكم الله خير

0

شارك هذا الرد


رابط المشاركة
شارك الرد من خلال المواقع ادناه
زوار
This topic is now closed to further replies.

  • يستعرض القسم حالياً   0 members

    لا يوجد أعضاء مسجلين يشاهدون هذه الصفحة .