• الإعلانات

    • فيصل الحربي

      تسجيل عضوية جديدة في المنتدى   01/31/2016

      السلام عليكم ورحمة الله وبركاته  عزيزي العضو الجديد :  حاليا رسالة الإيميل لتأكيد صحة إيميلكم تذهب للبريد العشوائي ( جاري حل المشكلة )  فإذا لم تجد رسالة التحقق من إيميلكم في صندوق الوارد لديكم إتجه للبريد العشوائي ( JUNK)  وقم بتفعيل إشتراككم من هناك   

jmidou

اعضاء جدد
  • عدد المشاركات

    4
  • تاريخ الانضمام

  • تاريخ اخر زياره

السمعه بالموقع

0 عادي

عن jmidou

  • الرتبة
    عضو جديد

معلومات الملف الشخصي

  • الجنس ذكر
  1. j'ai besoin de la procédure qui convertir la date en chaine arabe
  2. hHeure est une Heure nHeure est un entier nMinute est un entier nSeconde est un entier nAngleHeure est un entier nAngleMinute est un entier nAngleSeconde est un entier nLargeur est un entier nHauteur est un entier   // Récupère l'heure hHeure = Maintenant()   // Récupère les heure et minute nHeure = hHeure..Heure nMinute = hHeure..Minute nSeconde = hHeure..Seconde     // Récupère les dimensions du champ nLargeur = {sChampImage, indChamp}..Largeur nHauteur = {sChampImage, indChamp}..Hauteur   SI nLargeur < nHauteur ALORS nHauteur = nLargeur SI nHauteur < nLargeur ALORS nLargeur = nHauteur   // Démarre le dessin dFinDessin(sChampImage) dDébutDessin(sChampImage, dEffacer)   nCouleur est un entier = RVB(14,47,118)   // L'heure doit être passée en format 12:00 SI nHeure > 12 ALORS nHeure -= 12   // Calcule l'angle nAngleHeure = nHeure * (360 / 12) - 90 nAngleMinute = nMinute * (360 / 60) - 90 nAngleSeconde = nSeconde * (360 / 60) - 90   // Calcule le point central nX est un entier = nLargeur / 2 + 5 nY est un entier = nHauteur / 2   // Calcule le point X,Y de l'heure nHX est un entier = nX + 2 + (Cosinus(nAngleHeure) * (nX - (nLargeur/4))) nHY est un entier = nY + 2 +(Sinus(nAngleHeure) * (nY - (nLargeur/4)))   // Calcule le point X,Y de la minute nMX est un entier = nX + 2 +(Cosinus(nAngleMinute) * (nX - (nLargeur/5))) nMY est un entier = nY + 2 +(Sinus(nAngleMinute) * (nY - (nLargeur/5)))   // Calcule le point X,Y de la seconde nSX est un entier = nX + 2 +(Cosinus(nAngleSeconde) * (nX - (nLargeur/6))) nSY est un entier = nY + 2 +(Sinus(nAngleSeconde) * (nY - (nLargeur/6)))   // Dessine l'aiguille des secondes SI bAfficheSecondes ALORS dLigne(nX, nY, nSX, nSY, iGrisFonce, (nLargeur/50)) FIN   //-dLigne(nX, nY, nSX, nSY, iGrisFonce, (nLargeur/50)) FIN   // Dessine l'aiguille des minutes SI bAfficheSecondes ALORS  dLigne(nX, nY, nMX, nMY, iGrisFonce, (nLargeur/30)) // Dessine l'aiguille de l'heure SI bAfficheSecondes ALORS  dLigne(nX, nY, nHX, nHY, nCouleur, (nLargeur/40))   // Dessine le centre de l'horloge SI bAfficheSecondes ALORS  dCercle(nX - 2, nY - 2, nX + 4, nY + 4, iNoir, nCouleur) //FIN